hdu 1074 Doing Homework

本文介绍了一个通过最优调度减少因延迟提交作业而被扣分的问题。利用动态规划算法,实现了对作业完成顺序的有效规划,确保了扣分最小化的同时,还考虑了作业名称的字母顺序。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6299    Accepted Submission(s): 2708


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).  

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 
 
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English

Math


Hint

In the second test case, bothComputer->English->Math and Computer->Math->English leads to reduce3 points, but the

word "English" appears earlierthan the word "Math", so we choose the first order. That is so-calledalphabet order.

这题的大意是一个人需要完成他的作业,但是他的老师给他定了期限,每超过期限一天,就扣一分,问你如何安排做作业的顺序,才能使扣的分数最少,输出要扣的最小分数,并输出完成作业的顺序。(科目数目n<=15)

#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define N 100
struct node{
    int cost;
    int time;
    int pre;
    int now;
}dp[1<<15+1];
char s[20][N];
int need[N],close[N];
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        for(int i = 0 ; i < n ; i++)
            scanf("%s%d%d",s[i],&close[i],&need[i]);

        memset(dp,0,sizeof(dp));

        for(int i = 1 ; i < (1 << n) ; i++)    {
            dp[i].cost=INF;
            for(int j = n - 1 ; j >= 0 ; j--)    {
                int k=(1 << j);
                if( i & k)   {//查看第j个位置是否要填上
                    int st=dp[i-k].time+need[j]-close[j];
                    if(st<0)
                        st=0;
                    if(st+dp[i-k].cost<dp[i].cost) {
                        dp[i].cost=st+dp[i-k].cost;
                        dp[i].time=dp[i-k].time+need[j];
                        dp[i].now=j;//记录当前位置
                        dp[i].pre=i-k;//记录前面的位置为了递推
                    }
                }
            }
        }

        stack <int> S;
        int t = (1 << n) - 1;
        //for(int i=0;i<t;i++)
        printf("%d\n",dp[t].cost);
        while(t) {
            S.push(dp[t].now);
            t=dp[t].pre;
        }
        while(!S.empty()) {
            printf("%s\n",s[S.top()]);
            S.pop();
        }
    }
    return 0;
}

 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值