Wall Painting
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3487 Accepted Submission(s): 1146
Total Submission(s): 3487 Accepted Submission(s): 1146
Problem Description
Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with
different plans.
For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6.
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him?
You should tell Mr.Fang the answer from the first day to the n-th day.
Input
There are several test cases, please process till EOF.
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.
Output
For each test case, output N integers in a line representing the answers(mod 10
6 +3) from the first day to the n-th day.
Sample Input
4 1 2 10 1
Sample Output
14 36 30 8
Source
给一组数,对于第i次操作,输出 i个元素相互异或的和。
思维题,组合数,以及异或的性质
异或只有奇数个1有贡献
首先将这些所有的元素对应位数中1的个数存到数组a中
执行第i次
即从n中选出i个元素进行异或,如在第j为有a[j]个1,对与第j位的1来说,需要考虑1不丢失的所有方案从a[j]个1里面选奇数个1(这里设选k个,k记为选取有效的1的个数,即k的取值只能是奇数),再从n-a[j]里面选出剩下i-k个 = C(a[j], k)*C(a[j], i-k)得到贡献值 = 方案数 * 该二进制位上1的价值 = C(a[j], k) * C(n-a[j], i-k) * (1<<(j-1))
代码如下:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
typedef long long ll;
const int N=1e3+5;
const int MOD=1e6+3;
ll C[N][N]={0};
ll a[100]={0};
void init()
{
C[0][0]=1;
for(int i=0;i<=1000;i++)
{
for(int j=0;j<=1000;j++)
{
C[i+1][j]=(C[i+1][j]+C[i][j])%MOD;
C[i+1][j+1]=(C[i+1][j+1]+C[i][j])%MOD;
}
}
}
int main()
{
int n,t;
ll x;
init();
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
t=n;
while(t--)
{
scanf("%lld",&x);
for(int j=1;x;j++)
{
a[j]+=x&1;
x>>=1;
}
}
for(int i=1;i<=n;i++)
{
ll ans=0;
for(int j=1;j<=32;j++)
for(int k=1;k<=i&&k<=a[j];k+=2)
{
ans=(ans+(C[a[j]][k]%MOD)*(C[n-a[j]][i-k]%MOD)%MOD*(1ll<<(j-1))%MOD)%MOD;
}
printf("%lld",ans%MOD);
if(i==n)
printf("\n");
else
printf(" ");
}
}
return 0;
}