Play the Dice
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 3717 Accepted Submission(s): 1199
Special Judge
Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
Sample Input
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
Sample Output
3.50 0.00
Source
抽到再摇一次后只是多摇一次而已,与抽到的点数无关,因此把抽1,2,3.....k次的期望加起来就是总期望了
sum=a[1]+a[2]+a[3]+a[4]+a[5]+a[6];
p[1]=sum/n;
p[2]=sum/n*(m/n);
p[3]=sum/n*pow(m/n,2);
p[k]=sum/n*pow(m/n,k-1);
p(总)= p[1]+p[2]+...+p[k]=sum/(n-m);
p[1]=sum/n;
p[2]=sum/n*(m/n);
p[3]=sum/n*pow(m/n,2);
p[k]=sum/n*pow(m/n,k-1);
p(总)= p[1]+p[2]+...+p[k]=sum/(n-m);
(1)sum=0,则得到分数肯定是0(即使n==m得到分数也是0,因此要特判)
(2) n==m,则可以一直摇色子,输出inf
其余情况输出sum/(n-m)
AC代码:
#include<iostream>
#include<stdio.h>
using namespace std;
int n,a[210];
int m,b[210];
int main()
{
while(~scanf("%d",&n))
{
for(int i=1; i<=n; i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(int i=1; i<=m; i++)
scanf("%d",&b[i]);
int sum=0;
for(int i=1; i<=n; i++)
sum=sum+a[i];
if(sum==0)
{
printf("0.00\n");
continue;
}
if(n==m)
printf("inf\n");
else
{
double ans=sum*1.0/(n-m);
printf("%.2lf\n",ans);
}
}
return 0;
}