Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 55184 Accepted Submission(s): 24421
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
把1-n的数放在一个两两相邻的环中 要求相邻两个相加是素数 首先将1-40的素数打表 后深度搜索所有情况输出
#include<bits/stdc++.h>
using namespace std;
int a[20],vis[20],isprime[45],n;
void get_prime()
{
memset(isprime,0,sizeof(isprime));
for(int i=2;i<8;i++)
{
if(!isprime[i])
for(int j=i*i;j<45;j+=i)
{
isprime[j]=1;
}
}
}//素数打表,0是素数
int dfs(int step)
{
if(step==n+1&&!isprime[a[n]+a[1]])
{
for(int i=1;i<n;i++)
{
printf("%d ",a[i]);
}
printf("%d\n",a[n]);
return 0;
}
for(int i=2;i<=n;i++)
{
if(!vis[i]&&!isprime[i+a[step-1]])
{
a[step]=i;
vis[i]=1;
dfs(step+1);
vis[i]=0;
}
}
}
int main()
{
int k=1;
a[1]=1;
get_prime();
while(scanf("%d",&n)!=EOF)
{
memset(vis,0,sizeof(vis));
printf("Case %d:\n",k++);
dfs(2);
printf("\n");
}
}