hdu 5935 Car

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5935

 

题目描述:

 

Problem Description

Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record N positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0.

Now they want to know the minimum time that Ruins used to pass the last position.

 

 

Input

First line contains an integer T, which indicates the number of test cases.

Every test case begins with an integers N, which is the number of the recorded positions.

The second line contains N numbers a1, a2, ⋯, aN, indicating the recorded positions.

Limits
1≤T≤100
1≤N≤105
0<ai≤109
ai<ai+1

 

 

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum time.

 

 

Sample Input

 

1 3 6 11 21

 

 

Sample Output

 

Case #1: 4

 

 

Source

2016年中国大学生程序设计竞赛(杭州)

 

 

 

 

题目分析:

从后往前倒着做,最后一个时间肯定是1s

AC代码:

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
const long long int maxn=100005;
long long int T,N,cas=1,t,t0,d0,d,time;
long long int p[maxn];
int main()
{
    scanf("%lld",&T);
    while(T--)
    {
        scanf("%lld",&N);
        for(long long int i=1;i<=N;i++)
        {
            scanf("%lld",&p[i]);
        }
        p[0]=0;
        t0=1;
        t=1;
        d0=p[N]-p[N-1];
        for(long long int i=N-1;i>=1;i--)
        {
            d=p[i]-p[i-1];
            time=(d*t0+d0-1)/d0;
            d0=d;
            t0=time;
            t+=time;
        }
        printf("Case #%lld: %lld\n",cas++,t);
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值