Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 12818 | Accepted: 6479 |
Description
It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.
The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.
Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.
So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.
Input
The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.
Output
One line, consisting of an integer, which gives the minimum number of roads that we need to add.
Sample Input
Sample Input 1 10 12 1 2 1 3 1 4 2 5 2 6 5 6 3 7 3 8 7 8 4 9 4 10 9 10 Sample Input 2 3 3 1 2 2 3 1 3
Sample Output
Output for Sample Input 1 2 Output for Sample Input 2 0
题意:给一个无向连通图,至少添加几条边使得去掉图中任意一条边不改变图的连通性(即使得它变为边双连通图)。
思路:tarjan求双连通分量,然后缩点,缩点后的图是一个树形图,在其中寻找度为1的节点,设有x个,答案就是(x+1)/2。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1010;
struct data
{
int to,next;
} tu[N*N];
int n,m;
//dfn[]记录某个点被访问到的步数序号,low[]记录某个点或其子树回边的最小步数的点
int head[N],low[N],dfn[N];
int cut[N];//0表示该点不为割点,>0表示该点连通的子图个数
int sta[N];
int top;
int ip;
int step,rt_son;
int bridge;
int degree[N];
int cmp[N];
int suodian_cnt;
void init()
{
suodian_cnt=0;
top=0;
ip=0;
step=1;///遍历的步数
rt_son=0;///根的孩子数量
bridge=0;
memset(head,-1,sizeof(head));
memset(dfn, 0, sizeof(dfn));
memset(cut, 0, sizeof(cut));
memset(degree,0,sizeof(degree));
memset(cmp,0,sizeof(cmp));
}
void add(int u,int v)
{
tu[ip].to=v,tu[ip].next=head[u],head[u]=ip++;
}
void tarjan(int u,int fa)
{
dfn[u] = low[u] = step++;
sta[++top]=u;
for(int i = head[u]; i!=-1 ; i=tu[i].next) //访问以u为弧头的边
{
int to = tu[i].to;
if(!dfn[to])///表示未被访问的点
{
tarjan(to,u);
low[u]=min(low[u],low[to]);
if(low[to]>dfn[u])
bridge++;
}
else if(to!=fa)
low[u]=min(low[u],dfn[to]);
}
if(low[u]==dfn[u])
{
suodian_cnt++;
while(top)//出栈这里是重点
{
cmp[sta[top]]=suodian_cnt;
top--;
if(sta[top+1]==u)break;
}
// top--;
}
}
void solve()
{
for(int u=1;u<=n;u++)
{
for(int j = head[u]; j!=-1 ; j=tu[j].next) //访问以u为弧头的边
{
int to = tu[j].to;
if(cmp[to]!=cmp[u]) //不在同一集合连一条双向边
{
degree[cmp[u]]++;
degree[cmp[to]]++;
}
}
}
int ans=0;
for(int i=1;i<=suodian_cnt;i++)
{
if(degree[i]==2)
ans++;
}
printf("%d\n",(ans+1)/2);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
init();
int u,v;
for(int i=0;i<m;i++)
{
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
tarjan(1,-1);
if(rt_son>1)bridge+=rt_son;
solve();
}
}