问题
1009 Product of Polynomials (25 分)
This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N
1
a
N
1
N
2
a
N
2
… N
K
a
N
K
where K is the number of nonzero terms in the polynomial, N
i
and a
N
i
(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N
K
<⋯<N
2
<N
1
≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行
Sample Output:
3 3 3.6 2 6.0 1 1.6
结尾无空行
思路
利用map以key按大小顺序排序的特性存储第一个多项式。在第二个多项式的输入过程中与第一个多项式的每一项相乘,将结果保留在结果多项式(也是一个map),然后顺序输出就行。
代码
#include <bits/stdc++.h>
using namespace std;
map<int,float,greater<int>> mp;
map<int,float,greater<int>> res;
int n,m;
int main() {
int iNum;
float fNum;
cin>>n;
for (int i = 0; i < n; ++i) {
getchar();
scanf("%d %f",&iNum,&fNum);
mp[iNum] = fNum;
}
cin>>m;
int newiNum;
float newfNum;
for (int j = 0; j < m; ++j) {
getchar();
scanf("%d %f",&iNum,&fNum);
for (map<int,float>::iterator it=mp.begin();it!=mp.end();++it) {
newfNum = it->second*fNum;
newiNum = it->first+iNum;
if(res.count(newiNum)!=0){
res[newiNum] = res[newiNum]+newfNum;
if(res[newiNum] == 0){
res.erase(newiNum);
}
}
else{
res[newiNum] = newfNum;
if(res[newiNum] == 0){
res.erase(newiNum);
}
}
}
}
cout<<res.size();
if(res.size()!=0)
cout<<" ";
int count = 0;
for (map<int,float>::iterator it=res.begin();it!=res.end();++it) {
count++;
printf("%d %.1f",it->first,it->second);
if(count!=res.size())
cout<<" ";
}
cout<<endl;
return 0;
}
总结
res[newiNum] = res[newiNum]+newfNum;很容易写成res[newiNum] = res[newiNum]+fNum;要特别注意。