sort排序问题

问题

1006 Sign In and Sign Out (25 分)
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
结尾无空行
Sample Output:
SC3021234 CS301133
结尾无空行

思路

利用sort函数对两个结构体数组按照不同的规则排序。对于in数组,按照小时,分钟,秒的权重从小到大排序,最小的元素即为最早签到的人。对于out数组,按照小时,分钟,秒的权重从大到小排序,最小的元素即为最晚签离的人。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1010;
struct node{
    string id;
    int HH,MM,SS;
    node(){}
    node(string _id,int _HH,int _MM,int _SS):id(_id),HH(_HH),MM(_MM),SS(_SS){}
};
struct node in[maxn],out[maxn];
int m;
bool cmpIn(node a,node b){
    if(a.HH!=b.HH)
        return a.HH<b.HH;
    else{
        if(a.MM!=b.MM)
            return a.MM<b.MM;
        else
            return a.SS<b.SS;
    }
}

bool cmpOut(node a,node b){
    if(a.HH!=b.HH)
        return a.HH>b.HH;
    else{
        if(a.MM!=b.MM)
            return a.MM>b.MM;
        else
            return a.SS>b.SS;
    }
}

int main(){
    int H,M,S,H1,M1,S1;
    cin>>m;
    string id;
    for (int i = 0; i < m; ++i) {
        cin>>id;
        getchar();
        scanf("%d:%d:%d",&H,&M,&S);
        getchar();
        scanf("%d:%d:%d",&H1,&M1,&S1);
        node inPerson = node(id,H,M,S);
        in[i] = inPerson;
        node outPerson = node(id,H1,M1,S1);
        out[i] = outPerson;
    }
    sort(in,in+m,cmpIn);
    sort(out,out+m,cmpOut);
    cout<<in[0].id<<" "<<out[0].id<<endl;
    return 0;
}

总结

用上结构体的构造函数来简化代码。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值