Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 178988 Accepted Submission(s): 44485
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
Author
CHEN, Shunbao
Source
Recommend
直接用递归或者循环肯定超时,爆内存。因为
1 <= n <= 100,000,000
所以 关键在于 mod 7.
要找其循环周期。
如果是一个f()的话 循环周期是7
现在是两个f()所以 循环周期是49;
代码:
#include <iostream>
using namespace std;
int arr[50];
int main()
{
int n,a,b;
arr[1]=arr[2]=1;
while(cin>>a>>b>>n)
{
if(n==0) break;
for(int i=3; i<=50; i++)
{
arr[i]=(a*arr[i-1]+b*arr[i-2])%7;
}
cout<<arr[n%49]<<endl;
}
return 0;
}
Submit