HDU OJ 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 178988    Accepted Submission(s): 44485


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1021  1019  1009  1012 


直接用递归或者循环肯定超时,爆内存。因为   1 <= n <= 100,000,000

所以 关键在于  mod 7.

要找其循环周期。
如果是一个f()的话 循环周期是7
现在是两个f()所以 循环周期是49;

代码:

#include <iostream>  
using namespace std;  
int arr[50];  
int main()  
{  
    int n,a,b;  
    arr[1]=arr[2]=1;  
    while(cin>>a>>b>>n)  
    {  
        if(n==0) break;  
        for(int i=3; i<=50; i++)  
        {  
            arr[i]=(a*arr[i-1]+b*arr[i-2])%7;  
        }  
        cout<<arr[n%49]<<endl;  
    }  
    return 0;  
}  

Submit





 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值