kuangbin K - Count the string

本文介绍了一个字符串问题,通过KMP算法求解所有前缀在原字符串中的匹配次数总和,并提供了一段C++代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab

Sample Output
6

题解:

还是运用这个性质。
最短的前缀一定在较长的前缀出现过。
即[0,next[i]]一定在[0,i]出现过。
注意题目要求MOD 10007

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAXN = 200000 + 10;

char str[MAXN];
int len;
int nt[MAXN];
int res[MAXN];
void getNext()
{
    nt[0] = -1;
    int i = 0, j = -1;
    while (i <= len)
    {
        if (j == -1 || str[i] == str[j])
        {
            nt[++i] = ++j;
        }
        else
        {
            j = nt[j];
        }
    }
}

int main()
{
    int T;
    cin>>T;

    while(T--)
    {
       cin>>len;
       scanf("%s",str);
       getNext();
       for(int i=1;i<=len;i++)
       {
          res[i]=1;
       }

       for(int i=len;i>=1;i--)
       {
           res[nt[i]]+=res[i];
       }
        int sum=0;
        for(int i=len;i>=1;i--)
        {
            sum+=res[i]%10007;
        }
        cout<<sum%10007<<endl;

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值