B - Oulipo
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题解:
阅读题。KMP入门题。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1000000+100;
const int maxm = 10000+100;
int nt[maxn];
char s[maxn],t[maxm];
int slen,tlen;
void getNext()
{
int j,k;
j=0;k=-1;nt[0]=-1;
while(j<tlen)
{
if(k==-1||t[j]==t[k])
{
nt[++j]=++k;
}
else
{
k=nt[k];
}
}
}
int KMP_count()
{
int ans=0;
int i,j=0;
if(slen==1&&tlen==1)
{
if(s[0]==t[0])
{
return 1;
}
else
return 0;
}
getNext();
for(i=0;i<slen;i++)
{
while(j>0&&s[i]!=t[j])
j=nt[j];
if(s[i]==t[j])
j++;
if(j==tlen)
{
ans++;
j=nt[j];
}
}
return ans;
}
int main()
{
int T;
cin>>T;
while(T--)
{
scanf("%s",t);
scanf("%s",s);
slen = strlen(s);
tlen = strlen(t);
cout<<KMP_count()<<endl;
}
return 0;
}