Problem A: Arti cial Intelligence? 结题报告

本文详细阐述了解决人工智能问题A的过程,从问题理解、算法选择到实施步骤和最终结果的分析,展现了人工智能在解决复杂问题上的应用。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem A: Arti cial Intelligence?

Description

Physics teachers in high school often think that problems given as text are more demanding thanpure computations. After all, the pupils have to read and understand the problem rst! So they don't state a problem like U=10V, I=5A, P=?" but rather like You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?". However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished." OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.) Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems rst. That means, problems in which two of power, voltage and current are given
and the third is wanted. Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.
 
Input
The rst line of the input le will contain the number of test cases. Each test case will consist of one line containing exactly two data elds and some additional arbitrary words. A data eld will be of the form I=xA, U=xV or P=xW, where x is a real number. Directly before the unit (A, V or W) one of the pre xes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data elds adhere to the following grammar:
DataFiled ::= Concept '=' RealNumber [Profix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'
Additional assertions:
         *The equal sign (`=') will never occur in an other context than within a data eld.
         *There is no whitespace (tabs,blanks) inside a data eld.
         *Either P and U, P and I, or U and I will be given.
 
Output
For each test case, print three lines: a line saying Problem #k" where k is the number of the test case a line giving the solution (voltage, power or current, dependent on what was given), written without a pre x and with two decimal places as shown in the sample output a blank lineACM Contest Problems Archive University of Valladolid (SPAIN)
 
Sample Input
3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
 
Sample Output
Problem #1
P=900.00W
 
Problem #2
I=0.45A
 
Problem #3
U=1250000.00V

该题思路:
   1、从每一行中先找到‘=’字符,
   2、把它之后的数字通过一定办法存储成int型
   3、若后面跟着‘m’‘k’‘M’则相应的对int就行扩大和缩小
   4、根据单位相应的存储到I,P,U中
   5、利用2个参数,求剩下的参数

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
 
int main ()
{
    int n,j;
    scanf("%dn",&n);
    for (j=1;j<=n;j++)
    {
        char str[100],ch;
        int flag=0,flag1=0,key=0;
        double u=0,i=0,p=0,sum=0;
        double k=0,k1=0.1;
        gets(str);                           //得到字符串
            for (int cou=0;cou<strlen(str);cou++)
            {
                if (str[cou]=='n')
                    break;
                if (str[cou]=='=')       //找到'='
                {
                    flag1=1;
                }
                else if (flag1==1)      //得到数字
                {
                    if (flag==0&&str[cou]>='0'&&str[cou]<='9')
                        k=k*10+str[cou]-'0';
                    else if (str[cou]=='.')
                        flag=1;
                    else if (flag==1&&str[cou]>='0'&&str[cou]<='9')
                    {
                        k=k+(str[cou]-'0')*k1;
                        k1=k1*0.1;
                    }
                    else if (str[cou]=='m')   //单位
                    {
                        k=k/1000;
                    }
                    else if (str[cou]=='M')
                        k = k*1000000;
                    else if (str[cou]=='k')
                        k = k*1000;
                    else if (str[cou]=='A')
                        i=k;
                    else if (str[cou]=='W')
                        p=k;
                    else if (str[cou]=='V')
                        u=k;
                    else
                    {
                        k=0;k1=0.1;flag=0;flag1=0;
                    }
                }
            }
         if (j>1)
                printf("n");
            printf("Problem #%dn",j);   //输出
            //cout<< i << " " << u << " " << p << endl;
            if (u>0&&i>0)
            {
                p = u*i;
                printf("P=%.2lfWn",p);
            }
            else if (u>0&&p>0)
            {
                i = p/u;
                printf("I=%.2lfAn",i);
            }
            else if (p>0&&i>0)
            {
                u = p/i;
                printf("U=%.2lfVn",u);
            }
    }
}



爬虫Python学习是指学习如何使用Python编程语言来进行网络爬取和数据提取的过程。Python是一种简单易学且功能强大的编程语言,因此被广泛用于爬虫开发。爬虫是指通过编写程序自动抓取网页上的信息,可以用于数据采集、数据分析、网站监测等多个领域。 对于想要学习爬虫的新手来说,Python是一个很好的入门语言。Python的语法简洁易懂,而且有丰富的第三方库和工具,如BeautifulSoup、Scrapy等,可以帮助开发者更轻松地进行网页解析和数据提取。此外,Python还有很多优秀的教程和学习资源可供选择,可以帮助新手快速入门并掌握爬虫技能。 如果你对Python编程有一定的基础,那么学习爬虫并不难。你可以通过观看教学视频、阅读教程、参与在线课程等方式来学习。网络上有很多免费和付费的学习资源可供选择,你可以根据自己的需求和学习风格选择适合自己的学习材料。 总之,学习爬虫Python需要一定的编程基础,但并不难。通过选择合适的学习资源和不断实践,你可以逐步掌握爬虫的技能,并在实际项目中应用它们。 #### 引用[.reference_title] - *1* *3* [如何自学Python爬虫? 零基础入门教程](https://blog.youkuaiyun.com/zihong523/article/details/122001612)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [新手小白必看 Python爬虫学习路线全面指导](https://blog.youkuaiyun.com/weixin_67991858/article/details/128370135)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^koosearch_v1,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值