A Funny Game
Description
Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 10
6) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)
![]() Suppose that both Alice and Bob do their best in the game. You are to write a program to determine who will finally win the game. Input
There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 10
6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, if Alice win the game,output "Alice", otherwise output "Bob".
Sample Input 1 2 3 0 Sample Output Alice Alice Bob Source
POJ Contest,Author:Mathematica@ZSU
|
博弈第一招——对称博弈。
思路:无论对方怎么取,我都取与它对称(或者相反/一样的)
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)&&n)
{
if (n>=3) cout<<"Bob"<<endl;
else cout<<"Alice"<<endl;
}
return 0;
}