HDU-4734-F(x)

Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

Source

一道很简单的数位DP!!!!DP[pos][sum] 记录的是长度为pos小于等于sum的个数,这样就不用每次都初始化,我一开始DP记录的是长度为pos,前len-pos个数和sum的个数,因为每组样例DP的值不一定相同 如 1 10 dp[0][0] = 1; 而 2 100 dp[0][0] = 2;因此每次都需要初始化,这也是导致超时的原因。
这是一道很好的DP题!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
int dp[12][4600];
int A,B;
int F;
vector <int> digit;
void init(){
    F = 0;
    int t = 0;
    while(A){
        F += (A%10)*(1<<t);
        t++;
        A/=10;
    }
}
int dfs(int pos,int val,int done){
    if(pos==-1) return 1;
    if(!done&& ~dp[pos][val]) return dp[pos][val];
    int res = 0;
    int end = done?digit[pos]:9;
    for(int i = 0; i <= end; i++){
        if(val + i*(1<<pos) > F) break;
        res += dfs(pos-1,val + i*(1<<pos),done&&i==end);
    }
    if(!done) dp[pos][val] = res;
    return res;
}
int solve(int num){
    digit.clear();
    while(num){
        digit.push_back(num%10);
        num /= 10;
    }
    return dfs(digit.size()-1,0,1);
}
int main(){
    int ncase,T = 1;
    cin >> ncase;
    memset(dp,-1,sizeof dp);
    while(ncase--){
        cin >> A >> B;
        init();
        printf("Case #%d: %d\n",T++,solve(B));
    }
    return 0;
}




### 关于HDU - 6609 的题目解析 由于当前未提供具体关于 HDU - 6609 题目的详细描述,以下是基于一般算法竞赛题型可能涉及的内容进行推测和解答。 #### 可能的题目背景 假设该题目属于动态规划类问题(类似于多重背包问题),其核心在于优化资源分配或路径选择。此类问题通常会给出一组物品及其属性(如重量、价值等)以及约束条件(如容量限制)。目标是最优地选取某些物品使得满足特定的目标函数[^2]。 #### 动态转移方程设计 如果此题确实是一个变种的背包问题,则可以采用如下状态定义方法: 设 `dp[i][j]` 表示前 i 种物品,在某种条件下达到 j 值时的最大收益或者最小代价。对于每一种新加入考虑范围内的物体 k ,更新规则可能是这样的形式: ```python for i in range(n): for s in range(V, w[k]-1, -1): dp[s] = max(dp[s], dp[s-w[k]] + v[k]) ``` 这里需要注意边界情况处理以及初始化设置合理值来保证计算准确性。 另外还有一种可能性就是它涉及到组合数学方面知识或者是图论最短路等相关知识点。如果是后者的话那么就需要构建相应的邻接表表示图形结构并通过Dijkstra/Bellman-Ford/Floyd-Warshall等经典算法求解两点间距离等问题了[^4]。 最后按照输出格式要求打印结果字符串"Case #X: Y"[^3]。 #### 示例代码片段 下面展示了一个简单的伪代码框架用于解决上述提到类型的DP问题: ```python def solve(): t=int(input()) res=[] cas=1 while(t>0): n,k=list(map(int,input().split())) # Initialize your data structures here ans=find_min_unhappiness() # Implement function find_min_unhappiness() res.append(f'Case #{cas}: {round(ans)}') cas+=1 t-=1 print("\n".join(res)) solve() ```
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值