Intervals
Chiaki has n intervals and the i-th of them is [li, ri]. She wants to delete some intervals so that there does not exist three intervals a, b and c such that a intersects with b, b intersects with c and c intersects with a.
Chiaki is interested in the minimum number of intervals which need to be deleted.
Note that interval a intersects with interval b if there exists a real number x such that la ≤ x ≤ ra and lb ≤ x ≤ rb.
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1 ≤ n ≤ 50000) – the number of intervals.
Each of the following n lines contains two integers li and ri (1 ≤ li < ri ≤ 109) denoting the i-th interval. Note that for every 1 ≤ i < j ≤ n, li ≠ lj or ri ≠ rj.
It is guaranteed that the sum of all n does not exceed 500000.
Output
For each test case, output an integer m denoting the minimum number of deletions. Then in the next line, output m integers in increasing order denoting the index of the intervals to be deleted. If m equals to 0, you should output an empty line in the second line.
Sample Input
1
11
2 5
4 7
3 9
6 11
1 12
10 15
8 17
13 18
16 20
14 21
19 22
Sample Output
4
3 5 7 10
题意
给定若干个区间(保证左端点都不相同,且右端点都不相同),判断最少需要删除几个区间,才能使得剩下的区间中任取三个都不会两两相交,并列出删除的区间的编号。
思路
区间贪心问题。先将所有区间按左端点从小到大排列,再依次选三个区间判断是否两两相交:①若两两相交,则将这三个区间中右端点最大的区间删除(这样可以最大程度的减少区间影响范围),加入下一个区间再进行比较;②若不满足两两相交,则用下一个区间替换三个区间中右端点最小的区间(必然不可能与下个区间相交)再进行比较。
最后需要注意输出格式的处理。
代码实现
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 50001;
// 定义区间
struct node
{
int x, y;
int id;
} interval[maxn];
// 按照左端点从小到大排列
bool cmpL(node a, node b)
{
return a.x < b.x;
}
// 按照右端点从小到大排列
bool cmpR1(node a, node b)
{
return a.y < b.y;
}
// 按照右端点从大到小排列
bool cmpR2(node a, node b)
{
return a.y > b.y;
}
// 判断是否两两相交
bool judge(node a, node b, node c)
{
return b.x <= a.y && c.x <= a.y && c.x <= b.y;
}
int main()
{
int t, n;
vector<int> ans; // 删除区间编号记录
node tmp[4]; // 比较区间
scanf("%d", &t);
for (int i = 0; i < t; i++)
{
scanf("%d", &n);
int x, y;
for (int j = 1; j <= n; j++)
{
scanf("%d %d", &x, &y);
interval[j].x = x;
interval[j].y = y;
interval[j].id = j;
}
ans.clear();
sort(interval + 1, interval + n + 1, cmpL); // 先按左端点排序
tmp[1] = interval[1];
tmp[2] = interval[2];
for (int k = 3; k <= n; k++)
{
tmp[3] = interval[k];
sort(tmp + 1, tmp + 4, cmpL); // 排序便于判断相交
// 两种相交情况处理
if (judge(tmp[1], tmp[2], tmp[3]))
{
sort(tmp + 1, tmp + 4, cmpR1);
ans.push_back(tmp[3].id);
}
else
sort(tmp + 1, tmp + 4, cmpR2);
}
// 输出处理
sort(ans.begin(), ans.end());
printf("%d\n", ans.size());
if (ans.size() == 0)
printf("\n");
else
{
for (int j = 0; j < ans.size(); j++)
{
if (j > 0)
printf(" ");
printf("%d", ans[j]);
}
printf("\n");
}
}
}
参考