字符串排序

字符串排序

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
输入3个字符串,按字典序从小到大进行排序。
Input
输入数据有一行,分别为3个字符串,用空格分隔,每个字符串长度不超过100。
Output
输出排序后的三个字符串,用空格分隔。
Sample Input
abcd cdef bcde
Sample Output
abcd bcde cdef
Hint
 
Source

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		 Scanner input = new Scanner(System.in);
		 String a, b, c;
		 String d;
		 a = input.next();
		 b = input.next();
		 c = input.next();
		 if(a.compareTo(b) > 0) {
		     d = a;
		     a = b;
		     b = d;
		 }
		 if(a.compareTo(c) > 0) {
			 d = a;
			 a = c;
			 c = d;
		 }
		 if(b.compareTo(c) >0) {
			 d = b;
			 b = c;
			 c = d;
		 }
		 System.out.println(a+" "+b+" " + c);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值