题目
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the root of the resulting AVL tree in one line.
Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
解答
#include <iostream>
int max(int a, int b) { return a > b ? a : b; }
class Node
{
public:
int data;
int height;
Node *left;
Node *right;
Node(int d = 0, Node *p = nullptr, Node *q = nullptr) : data(d), height(0), left(p), right(q) {}
};
int getHeight(Node *r) { return !r ? -1 : r->height; }
class AVL
{
private:
void traverse(Node *r)
{
if (!r)
return;
std::cout << r->data << '-' << r->height << ' ';
traverse(r->left);
traverse(r->right);
}
Node *insert(Node *r, int d)
{
if (!r)
r = new Node(d);
else if (d < r->data)
{
r->left = insert(r->left, d);
if (getHeight(r->left) - getHeight(r->right) == 2)
{
if (d < r->left->data)
r = singleLeftRotation(r);
else
r = doubleLeftRightRotation(r);
}
} else if (d > r->data)
{
r->right = insert(r->right, d);
if (getHeight(r->right) - getHeight(r->left) == 2)
{
if (d > r->right->data)
r = singleRightRotation(r);
else
r = doubleRightLeftRotation(r);
}
}
r->height = max(getHeight(r->left), getHeight(r->right)) + 1;
return r;
}
public:
Node *root;
AVL()
{
root = nullptr;
}
void insert(int d) { root = insert(root, d); }
void traverse() { traverse(root); }
Node *findMin(Node *r)
{
if (!r->left)
return r;
else
return findMin(r->left);
}
static Node *singleLeftRotation(Node *r)
{
Node *p = r->left;
r->left = p->right;
p->right = r;
r->height = max(getHeight(r->left), getHeight(r->right)) + 1;
p->height = max(getHeight(p->left), r->height) + 1;
return p;
}
static Node *singleRightRotation(Node *r)
{
Node *p = r->right;
r->right = p->left;
p->left = r;
r->height = max(getHeight(r->left), getHeight(r->right)) + 1;
p->height = max(getHeight(p->right), r->height) + 1;
return p;
}
static Node *doubleLeftRightRotation(Node *r)
{
r->left = singleRightRotation(r->left);
return singleLeftRotation(r);
}
static Node *doubleRightLeftRotation(Node *r)
{
r->right = singleLeftRotation(r->right);
return singleRightRotation(r);
}
};
int main()
{
int n;
int d;
AVL t;
std::cin >> n;
for (int i = 0; i < n; ++i)
{
std::cin >> d;
t.insert(d);
}
std::cout << t.root->data << '\n';
return 0;
}