HDU1385 Minimum Transport Cost(floyd+标记路径)

本文探讨了Floyd算法在解决最小运输成本问题中的应用,强调了不仅需要标记路径,还需要考虑输出最小字典序的路径。通过举例说明,解释了如何确定最短路径及其子路径的字典序,并指出理解这一原理对于解决问题至关重要。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11029    Accepted Submission(s): 3062


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

以为理解了floyd,其实还远远不够。

对于本题,不止是标记路径,还要求输出最小字典序;

比如有这样三条边 

1->2   1

2->3   1

1->3   2

则有两种路径1->2->3和1->3

1->2->3的字典序较小,这里输出1->2->3;

对于输出路径,大致的原理就是一句话:最短路径的子路径也是最短路径

过程我就不分析了,想想还是很好理解的

#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))

using namespace std;
const int inf=0x3f3f3f3f;
int e[105][105],p[105][105],cost[105];
int n;
void init()
{
    for(int i=0;i<=n;i++)
    {
        for(int j=0;j<=n;j++)
        {
            if(i==j)
            e[i][j]=0;
            else
            e[i][j]=inf;
            p[i][j]=j;
        }
    }
}
void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(e[i][k]!=inf&&e[k][j]!=inf)
                {
                    int tmp=e[i][k]+e[k][j]+cost[k];
                    if(e[i][j]>tmp)
                {
                    e[i][j]=tmp;
                    p[i][j]=p[i][k];
                }
                else if(e[i][j]==tmp&&p[i][j]>p[i][k])
                p[i][j]=p[i][k];
                }
            }
        }
    }
}
int main()
{
   while(~scanf("%d",&n)&&n)
   {
       init();
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=n;j++)
           {
               scanf("%d",&e[i][j]);
               if(e[i][j]==-1)e[i][j]=inf;
           }
       }
       for(int i=1;i<=n;i++)scanf("%d",&cost[i]);
       floyd();
       int st,ed;
       while(~scanf("%d%d",&st,&ed))
       {
           if(st==-1&&ed==-1)break;
           printf("From %d to %d :\n",st,ed);
           printf("Path: %d",st);
           int u=st;
           while(u!=ed)
           {
               printf("-->%d",p[u][ed]);
               u=p[u][ed];
           }
           puts("");
           printf("Total cost : %d\n\n",e[st][ed]);
       }
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值