PAT_甲级_1102

1102

Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
'- -
0 -
2 7
'- -
'- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

二叉树的静态数组实现。
注意点:
1、用getchar()过滤换行符
2、=和==号

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
struct node{
    int lchild, rchild;
}Node[20];
int n;
bool find_g[20] = {false};
int num_in = 0;

void inOrder(int root)
{
    if (root == -1) return;
    inOrder(Node[root].lchild);

    cout << root;
    num_in++;
    if (num_in < n) {
        cout << ' ';
    }
    inOrder(Node[root].rchild);
}

int num_level = 0;
void levelOrder(int root)
{
    queue<int> q;
    q.push(root);
    while(!q.empty()) {
        int now = q.front();
        q.pop();
        cout << now;
        num_level++;
        if (num_level < n) {
            cout << ' ';
        }
        if (Node[now].lchild != -1) {
            q.push(Node[now].lchild);
        }
        if (Node[now].rchild != -1) {
            q.push(Node[now].rchild);
        }
    }
}
int main()
{
    cin >> n;
    for (int i = 0; i < n; i++) {
        char a, b;
        getchar();
        scanf("%c %c", &a, &b);
        if (a >= '0' && a <= '9') {
            Node[i].rchild = a - '0';
            find_g[a - '0'] = true;
        } else {
            Node[i].rchild = -1;
        }
        if (b >= '0' && b <= '9') {
            Node[i].lchild = b - '0';
            find_g[b - '0'] = true;
        } else {
            Node[i].lchild = -1;
        }
    }
    int gen;
    for (gen = 0; gen < n; gen++) {
        if (find_g[gen] == false) break;
    }
    levelOrder(gen);
    cout << endl;
    inOrder(gen);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值