1086 Tree Traversals Again
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目意思:给出出入栈顺序,即前序和中序遍历,求后序遍历。
1、在判断的时候,刚开始把序号全当作一位数做的,导致最后一个例子一直段错误,找了好久才找到bug
2、前序、中序数组存储反了
#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stack>
#include<vector>
using namespace std;
int n;
vector<int> in_arr;
vector<int> pre_arr;
vector<int> post_arr;
stack<int> s;
struct node{
node* lchild;
node* rchild;
int data;
};
node* create(int preL, int preR, int inL, int inR)
{
if (preL > preR) {
return NULL;
}
node* root = new node;
root->data = pre_arr[preL];
int k;
for (k = inL; k <= inR; k++) {
if (pre_arr[preL] == in_arr[k]) {
break;
}
}
int numLeft = k - inL;
root->lchild = create(preL + 1, preL + numLeft, inL, k - 1);
root->rchild = create(preL + numLeft + 1, preR, k + 1, inR);
return root;
}
int num = 0;
void post(node* root)
{
if (root == NULL)
{
return;
}
post(root->lchild);
post(root->rchild);
cout << root->data;
num++;
if (num < n) cout << ' ';
}
int main()
{
cin >> n;
getchar();
for (int i = 0; i < 2 * n; i++) {
string temp;
getline(cin, temp);
if (temp.size() == 3) {
in_arr.push_back(s.top());
s.pop();
} else {
string temp_2 = temp.substr(5, temp.size() - 5);
s.push(atoi(temp_2.c_str()));
pre_arr.push_back(atoi(temp_2.c_str()));
}
}
node* root = create(0, n - 1, 0, n - 1);
post(root);
return 0;
}