PAT_甲级_1086

1086 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目意思:给出出入栈顺序,即前序和中序遍历,求后序遍历。
1、在判断的时候,刚开始把序号全当作一位数做的,导致最后一个例子一直段错误,找了好久才找到bug
2、前序、中序数组存储反了

#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stack>
#include<vector>
using namespace std;
int n;
vector<int> in_arr;
vector<int> pre_arr;
vector<int> post_arr;
stack<int> s;
struct node{
    node* lchild;
    node* rchild;
    int data;
};
node* create(int preL, int preR, int inL, int inR)
{
    if (preL > preR) {
        return NULL;
    }
    node* root = new node;
    root->data = pre_arr[preL];
    int k;
    for (k = inL; k <= inR; k++) {
        if (pre_arr[preL] == in_arr[k]) {
            break;
        }
    }
    int numLeft = k - inL;
    root->lchild = create(preL + 1, preL + numLeft, inL, k - 1);
    root->rchild = create(preL + numLeft + 1, preR, k + 1, inR);
    return root;
}
int num = 0;
void post(node* root)
{
    if (root == NULL)
    {
        return;
    }
    post(root->lchild);
    post(root->rchild);
    cout << root->data;
    num++;
    if (num < n) cout << ' ';
}
int main()
{
    cin >> n;
    getchar();
    for (int i = 0; i < 2 * n; i++) {
        string temp;
        getline(cin, temp);
        if (temp.size() == 3) {
            in_arr.push_back(s.top());
            s.pop();
        } else {
            string temp_2 = temp.substr(5, temp.size() - 5);
            s.push(atoi(temp_2.c_str()));
            pre_arr.push_back(atoi(temp_2.c_str()));
        }
    }
    node* root = create(0, n - 1, 0, n - 1);
    post(root);
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值