Reversing Linked List

该博客主要讨论了一种链表操作问题,即给定一个常数K和一个单链表L,如何反转每K个节点。通过输入链表的节点信息和K值,程序实现对链表的K节点反转并输出结果。思路是使用数组存储节点首尾地址,先排序再反转,最后输出新的链表顺序。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

思路:用数组存取首尾地址,然后先进行排序,然后再进行反转,将反转的下一个地址指向新的元素

解题代码:

#include<bits/stdc++.h>
using namespace std;
const int MAX = 100005;
int arr[MAX]={}, nex[MAX]={}, head[MAX]={};
int beginlist, N, K;

int main() 
{
	scanf("%d %d %d", &beginlist, &N, &K);
	for (int i = 0;i < N;i++) 
	{
		int Hd, num, nt;
		cin>>Hd>>num>>nt;
		arr[Hd] = num;
		nex[Hd] = nt;
	}
	int sum = 0;
	while (beginlist != -1)       // 当尾结点为 -1 时结束 
	{   
		head[sum] = beginlist;   // 记录所有的首地址
		sum++;
		beginlist = nex[beginlist];  // 找下一个结点 
	}
	for (int i = 0;i < sum - sum % K;i += K) 
	{  
		for (int j = 0;j < K / 2;j++)         // 反转链表
		{  
			int t = head[i + j];
			head[i + j] = head[i + K - j - 1];
			head[i + K - j - 1] = t;
		}
	}
	for (int i = 0;i < sum - 1;i++)
		cout << setfill('0') << setw(5) << head[i] << " " << arr[head[i]] << " " << setfill('0') << setw(5) << head[i + 1] << endl;
	cout << setfill('0') << setw(5) << head[sum - 1] << " " << arr[head[sum-1]] << " -1";
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不刻苦的李

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值