1561. PRIME

1561. PRIME

Description

A prime number is a natural number which has exactly two distinct natural number divisors: 1 and itself. The first prime number is 2. Can you write a program that computes the nth prime number, given a number n <= 10000?

Input

The input contains just one number which is the number n as described above.
The maximum value of n is 10000.

Output

The output consists of a single line with an integer that is the nth prime number.

Sample Input

30

Sample Output

113

// source code of submission 967979, Zhongshan University Online Judge System
#include <iostream>
#include <cmath>
using namespace std;

bool isPrime(int k)
{
    bool ans = true;
    for(int i = 2;i <= sqrt(double(k));i++)
    {
        if( k % i == 0)
            ans = false;
    }
    return ans;
}

int main ()
{
    int n,i = 0,m = 2;
    cin >> n;
    while (i != n)
    {
        if(isPrime(m))
            i++;
        m++;
    }
    cout << m-1 << endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值