1561. PRIME
Description
A prime number is a natural number which has exactly two distinct natural number divisors: 1 and itself. The first prime number is 2. Can you write a program that computes the nth prime number, given a number n <= 10000?
Input
The input contains just one number which is the number n as described above.
The maximum value of n is 10000.
Output
The output consists of a single line with an integer that is the nth prime number.
Sample Input
30
Sample Output
113
// source code of submission 967979, Zhongshan University Online Judge System
#include <iostream>
#include <cmath>
using namespace std;
bool isPrime(int k)
{
bool ans = true;
for(int i = 2;i <= sqrt(double(k));i++)
{
if( k % i == 0)
ans = false;
}
return ans;
}
int main ()
{
int n,i = 0,m = 2;
cin >> n;
while (i != n)
{
if(isPrime(m))
i++;
m++;
}
cout << m-1 << endl;
return 0;
}