Catch That Cow POJ - 3278
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
刚写的时候数组越界,debug发现没有在没有考虑位置为负的情况,还有要先判断是否越界在判断是否访问过。
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=100010;
int n,k;
int vis[maxn];
int ans;
struct node{
int x;
int step;
};
bool judge(int x)
{
if(x<0||x>=maxn)
{
return true;
}
if(vis[x])
{
return true;
}
return false;
}
void bfs()
{
node cur,next;
queue<node>q;
cur.x=n;
cur.step=0;
q.push(cur);
vis[n]=true;
while(!q.empty())
{
cur=q.front();
q.pop();
int i,nx;
if(cur.x==k)
{
ans=cur.step;
return;
}
next.x=cur.x+1;
if(!judge(next.x))
{
vis[next.x]=true;
next.step=cur.step+1;
q.push(next);
}
next.x=cur.x-1;
if(!judge(next.x))
{
vis[next.x]=true;
next.step=cur.step+1;
q.push(next);
}
next.x=cur.x*2;
if(!judge(next.x))
{
vis[next.x]=true;
next.step=cur.step+1;
q.push(next);
}
}
}
int main()
{
cin>>n>>k;
memset(vis,0,sizeof(vis));
bfs();
cout<<ans;
return 0;
}