Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int main() {
int a, b, c;
cin >> a >> b;
c = a + b;
string str = to_string(c);
string ans = "";
int x = 0;
for(int i = str.size() - 1; i >= 0; i--) {
x++;
ans += str[i];
if(x % 3 == 0) {
x = 0;
if(i != 0 && str[i - 1] != '-') ans += ',';
}
}
for(int i = ans.size() - 1; i >= 0; i--)
cout << ans[i];
return 0;
}