1001 A+B Format (20分) 【模拟】

本文介绍了一个简单的程序设计问题:如何计算两个整数的和,并将结果显示为标准格式,即每三位数字用逗号分隔。文章通过示例输入和输出展示了具体的实现过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:

-1000000 9

Sample Output:

-999,991

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

int main() {
	int a, b, c;
	cin >> a >> b;
	c = a + b;
	string str = to_string(c);
	string ans = "";
	int x = 0;
	for(int i = str.size() - 1; i >= 0; i--) {
		x++;
		ans += str[i];
		if(x % 3 == 0) {
			x = 0;
			if(i != 0 && str[i - 1] != '-')	ans += ',';
		}
	}
	for(int i = ans.size() - 1; i >= 0; i--)
		cout << ans[i];
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值