Elevator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 58340 Accepted Submission(s): 31975
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2 3 2 3 1 0
Sample Output
17 41
题意:电梯上行一层花6s,下行一层花4s,停留花5s,计算总时间。
模拟一下,在输入的同时计算就可以。
#include <stdio.h>
int main()
{
int T;
int sum;
int i,a[2];
while(scanf("%d",&T),T)
{
a[0]=0;
sum=5*T;
for(i=1;i<=T;i++)
{
scanf("%d",&a[1]);
if(a[1]>a[0])
sum+=(a[1]-a[0])*6;
else if(a[0]>a[1])
sum+=(a[0]-a[1])*4;
a[0]=a[1];
}
printf("%d\n",sum);
}
return 0;
}