HDU1008Elevator

本文介绍了一个简单的电梯调度问题,通过给定楼层请求列表,计算电梯完成所有请求所需的总时间。文章提供了一段C++实现代码,并解释了算法的基本思想。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

思路:

水题一个,nextpost记录下一个要去的位置,lastpost记录上一个要去的位置。

  1. nextpost大于lastpost时,相减乘6
  2. nextpost大于lastpost时,相减乘4
  3. 每输入一个,sum必加5

代码如下

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<stdlib.h>
#define MAXN 101
using namespace std;
int main()
{
    int N, i, nextpost, lastpost,sum;
    while (cin >> N&& N) {
        lastpost = 0;
        sum = 0;
        for (i = 0; i < N; i++) {
            cin >> nextpost;
            if (nextpost < lastpost)
                sum = sum + (lastpost - nextpost) * 4;
            else {
                sum = sum + (nextpost - lastpost) * 6;
            }
            lastpost = nextpost;
            sum = sum + 5;
        }
        cout << sum << endl;

    }
    return 0;
}
//水题一个
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值