Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题目大意:
给定长度为n的数列整数以及整数S。求出总和不小于S的连续子序列的长度的最小值。如果解不存在,则输出0。
解题思路:
该题为求一连续子序列。右端点右移sum值增大,左端点右移sum值减小。使用尺取法,先将s=t=sum=0初始化。只要sum小于S,sum右加,t右移。若t移到终点仍无法满足sum>=S则终止。否则,更新res=min(res,t-s)。然后将sum左减,s右移一位,返回sum小于S一步。
代码如下:
#include<iostream>
#include<memory.h>
#include<algorithm>
using namespace std;
long long int a[100005];
int n,S;
void solve();
int main()
{
int t;
int i;
cin>>t;
while(t--)
{
cin>>n>>S;
for(i=0;i<n;i++)
cin>>a[i];
solve();
}
return 0;
}
void solve()
{
int res=n+1;
int s=0,t=0;
long long int sum=0;
for(;;)
{
while(t<n&&sum<S)
{
sum+=a[t++];
}
if(sum<S)
break;
res=min(res,t-s);
sum-=a[s++];
}
if(res>n)
res=0;
cout<<res<<endl;
}