Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
InputThe first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);OutputFor each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.Sample Input
Now please try your lucky.
2 100 -4Sample Output
1.6152 No solution!
#include<stdio.h>
#include<iostream>
#include<vector>
#include <algorithm>
#include<math.h>
using namespace std;
double judge(double a)
{
return 8*pow(a,4.0)+7*pow(a,3.0)+2*a*a+3*a+6;
}
int main()
{
int cas;
scanf("%d",&cas);
while(cas--){
int Y;
scanf("%d",&Y);
double l,r,m;
if( judge(0) <= Y && Y <= judge(100) ) {
l = 0;
r = 100;
while( r - l > 1e-6 ) {
m = (l + r) / 2;
double ans = judge(m);
if( ans > Y ) {
r = m - 1e-7;
}else
l = m + 1e-7;
}
printf("%.4lf\n", (l + r) / 2 );
}else
printf("No solution!\n");
}
}