POJ3744 Scout YYF I 矩阵快速幂

本题用到的是条件概率公式

并且要知道一个结论,就是如果没有踩到第i个雷,那么人一定回到第pos[i]+1个位置

设p(i)表示没踩到第i个雷

那么

p(1,2,3,4.。。n) = p(1)*p(2|1)*p(3|1,2)*........*p(n|1,2,3......n-1)

右部约分后等于左部


Scout YYF I
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4381 Accepted: 1144

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of  p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with  EOF.
Each test case contains two lines.
The First line of each test case is  N (1 ≤  N ≤ 10) and  p (0.25 ≤  p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>

using namespace std;


double p;
int n;
int pos[15];

//dp[i]=dp[i-1]*p+dp[i-1]*(1-p)
// [ p , 1-p] * [ dp[i-1] ]   = [ dp[i]  ]
// [ 1 ,  0 ]   [ dp[i-2] ]     [ dp[i-1]]
// dp[0]=0 dp[1]=1

struct Matrix
{
    double element[2][2];
    Matrix operator* (Matrix);
    Matrix power(int);
    void init();
};

void Matrix::init(){
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++) element[i][j]=0;
}

Matrix Matrix::operator* (Matrix param)
{
    Matrix product;
    product.init();
    for (int i=0; i<2; i++)
        for (int j=0; j<2; j++)
            for (int k=0; k<2; k++)
                product.element[i][j]+=element[i][k]*param.element[k][j];
    return product;
}

Matrix Matrix::power(int exp)
{
    Matrix res,A;
    A=*this;
    res.init();
    for(int i=0;i<2;i++) res.element[i][i]=1;
    while(exp){
        if(exp&1) res=A*res;
        exp>>=1;
        A=A*A;
    }
    return res;
}
int main(){
    while(~scanf("%d%lf",&n,&p)){
        for(int i=0;i<n;i++)
            scanf("%d",&pos[i]);
        sort(pos,pos+n);
        Matrix m,pows;
        double ret=1;
        m.element[0][0]=p; m.element[0][1]=1-p;
        m.element[1][0]=1; m.element[1][1]=0;
        pows=m.power(pos[0]-1);
        ret*=(1-pows.element[0][0]);
        //不要简单相加
        //需要注意没踩到pos[i]的地雷,那么人一定站在pos[i+1]
        for(int i=1;i<n;i++){
            if(pos[i]==pos[i-1]) continue;
            pows=m.power(pos[i]-pos[i-1]-1);
            ret*=(1-pows.element[0][0]);
        }
        printf("%.7lf\n",ret);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值