HDU-1213-How Many Tables

本文介绍了一个关于生日聚会中如何最少地分配桌子数量的问题,使用并查集算法解决朋友间的关系,确保认识的朋友坐在同一张桌子上。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

点击打开链接


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32673    Accepted Submission(s): 16300


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
题意:生日聚会,是朋友的坐在一起,求要多少张桌子。

思路:直接并查集,集合的数量就是桌子的数量,所以只要找最后有多少个根节点就行了

#include<stdio.h>
#include<string.h>
using namespace std;
int n,par[1010];
bool flag[1010];	//记录结点是否为根节点,若为1是根节点
void init()		//初始化
{
	for(int i=1;i<=n;i++)
		par[i]=i;
}
int find(int x)		//找根节点
{
	return x==par[x]?x:par[x]=find(par[x]);
}
void Union(int a,int b)	//把朋友放到一个集合(树)里
{
	int fa=find(a),fb=find(b);
	if(fa!=fb)
	par[fa]=fb;
}
int main()
{
	int T,g,i,a,b;
	scanf("%d",&T);
	while(T--)
	{
		int ans=0;
	
		scanf("%d%d",&n,&g);
			init();		
		for(i=1;i<=g;i++)
		{
			scanf("%d%d",&a,&b);
			Union(a,b); 
		}
		memset(flag,0,sizeof(flag));
		for(i=1;i<=n;i++)
		flag[find(i)]=1;	//find(i)找到i的根节点,把根节点标记为1,非根节点标记为0
		for(i=1;i<=n;i++)
		if(flag[i])
		ans++;
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值