Minimal coverage
The Problem
Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].
The Input
The first line is the number of test cases, followed by a blank line.
Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".
Each test case will be separated by a single line.
The Output
For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).
Print a blank line between the outputs for two consecutive test cases.
Sample Input 在别人的博客里发现几组数据
2 1 -1 0 -5 -3 2 5 0 0 1 -1 0 0 1 0 0
7 1 -1 0 -5 -3 2 5 0 0 1 -1 0 0 1 0 0 10 -2 5 -1 6 -1 3 0 4 1 5 2 6 3 7 7 8 8 10 8 9 0 0 10 -2 5 -1 6 -1 3 0 4 1 5 2 6 3 7 8 10 8 9 0 0 10 2 5 5 3 2 3 2 5 0 0 10 0 10 0 10 0 0 6 0 2 2 4 4 6 6 8 0 0
Sample Output
0 1 0 1
0 1 0 1 4 -1 6 3 7 7 8 8 10 0 0 1 0 10 3 0 2 2 4 4 6
题意:数轴上有多个闭区间[Li,Ri],选择尽量少的区间覆盖一条指定线段[0,M];
[分析]:把各个区间按照Li从小到大排序,如果区间i的终点<线段起点,直接pass,否则如果线段的起点处于区间内,则找出区间Ri最大的那个,然后把线段的起点更新为Ri最大的那个,继续查找下一个区间,直到找到Ri>m,结束查找.
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
int a,b;
}ss[100010];
int cmp(node A,node B) //将区间按左端点从小到大排列,如果左端点相同,按右端点从小到大排列
{
if(A.a==B.a)
return A.b<B.b;
return A.a<B.a;
}
int main()
{
int n,m,l,s,flag,cnt,i,f,t,aa[100010][2],k,g;
scanf("%d",&n);
while(n--)
{
k=0;flag=0;l=0;
scanf("%d",&m);
while(scanf("%d%d",&ss[l].a,&ss[l].b)!=EOF&&(ss[l].a!=0||ss[l].b!=0))
{
l++;
}
sort(ss,ss+l,cmp);
f=0;s=0;cnt=1;
for(i=0;i<l;i++)
{
if(s>ss[i].b) //如果区间的右端点比线段的起点小,直接不用考虑
{
continue;
}
else if(s>=ss[i].a) //如果线段的起点处于区间内,并且该区间的右端点比上一个满足条件的区间的右端点大,即覆盖区域更往后,则将该区间的左右端点记录下来
{
if(f<=ss[i].b)
{
f=ss[i].b;
g=ss[i].a;
}
}
else if(s<ss[i].a) //当区间左端点>线段起点,这时候要更新线段起点为之前区间覆盖最远的地方
{
if(f<ss[i].a) //如果之前区间覆盖最远的地方<当前区间的左端点,说明中间中断了,不可能将线段覆盖完,flag=1,直接跳出循环
{
flag=1;
break;
}
else
{
aa[k][0]=g;
aa[k][1]=f;
k++;
s=f;
i--;
cnt++;
}
}
if(f>=m) //当把线段覆盖完了,就不用考虑后面的区间,提前结束循环
break;
}
if(f<m||flag==1)
printf("0\n");
else
{
printf("%d\n",cnt);
aa[k][0]=g;aa[k][1]=f;k++; //最后一组符合条件的区间未加入aa数组中
for(i=0;i<k;i++)
{
printf("%d %d\n",aa[i][0],aa[i][1]);
}
}
if(n)
printf("\n");
}
}