hd 2317 Nasty Hacks

 
<h1 style="COLOR: #1a5cc8">Nasty Hacks</h1><span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;FONT-WEIGHT: bold">Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2147    Accepted Submission(s): 1696
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -10<sup>6</sup> ≤ r, e ≤ 10<sup>6</sup> and 0 ≤ c ≤ 10<sup>6</sup>.</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">3
0 100 70
100 130 30
-100 -70 40</div>
 

Sample Output
  
  
advertise does not matter do not advertise
 

Source
 

Recommend
zty   |   We have carefully selected several similar problems for you:   2320  2304  2322  2321  2323 
 

 
#include<stdio.h>
int main()
{
    int t,r,e,c,p;
    while(scanf("%d",&t)!=EOF)
    {
      while(t--)
      {
        scanf("%d%d%d",&r,&e,&c);
        //c=(c<0?(-c):c);
        p=e-c;
        if(r>p)
        printf("do not advertise\n");
        else if(r==p)
        printf("does not matter\n");
        else
        printf("advertise\n");
                }
                              }
return 0;    
}
//为单词拼写浪费20分钟实在不值得
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值