Description
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!
Input
The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

Sample Input
1 2 1 3 1 4 2 2 2 3 2 4 2 11 4 11 0 0
Sample Output
1 0 1 2 3 5 144 51205
题意:用1*2的小方格填满n*m的方案数
分析:轮廓线DP,由一格一格状态转化
代码;
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <queue>
#define mem(p,k) memset(p,k,sizeof(p));
#define rep(a,b,c) for(int a=b;a<c;a++)
#define pb push_back
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
const int maxn=10;
int n,m,ans;
ll dp[2][100000];
int main()
{
while(~scanf("%d%d",&n,&m) && n+m){
if(n*m&1){
cout<<0<<endl;continue;
}
if(n<m)swap(n,m);
mem(dp,0);
int now=0;
dp[now][(1<<m)-1]=1;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
now^=1;
mem(dp[now],0);
for(int k=0;k<(1<<m);k++){
if(dp[now^1][k]){
dp[now][k^(1<<j)]+=dp[now^1][k];
if(j && k&(1<<j) && !(k&1<<j-1)){
dp[now][k^1<<j-1]+=dp[now^1][k];
}
}
}
}
}
cout<<dp[now][(1<<m)-1]<<endl;
}
return 0;
}