巧妙处理最长公共子序列

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
int a[100005];
int main()
{
    int k ;
    int t;
    scanf("%d", &t);
    int cntt = 1;
    while( t--)
    {
        memset( a, 0, sizeof ( a ));
        scanf("%d", &k);
        int i;
        int f = 0;
        for( i =0; i<k ; i++)
        {
            scanf("%d", &a[i]);
        }
        int st = 0, en = 0;///最大子序列的起始点
        int pos = 0;///当前起始点
        int sum = 0;
        int maxx = a[0];
        for( i =0; i<k; i++)
        {
            sum = sum + a[i];
            if( sum < a[i] )///前面和为负数, 则舍去
            {
                pos  = i;
                sum = a[i];
            }
            if( sum >  maxx )
            {
                st = pos;   更新
                en  = i;
                maxx = sum;
            }


        }
        printf("Case %d:\n%d %d %d\n", cntt++, maxx, st+1 ,en+1 );
        if( t != 0)
            printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值