Power of Cryptography

本文介绍了一种通过双精度浮点数计算特定形式整数根的有效方法,利用数学库中的幂函数并结合四舍五入技巧,实现了在限定条件下的整数n次根求解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


C - Power of Cryptography
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu

Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n  th. power, for an integer k (this integer is what your program must find).

Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10  101 and there exists an integer k, 1<=k<=10  9 such that k  n = p.

Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

Sample Input

2 16
3 27
7 4357186184021382204544

Sample Output

4
3
1234

double最大可到1e308,注:double占8个字节,它的范围大,但精度小,但因为是指数,double精度小不会影响,故可以用double

四舍五入方法:(int)(x+0.5)或(round)x;

#include<stdio.h>
#include<math.h>
int main()
{
	double n,k,x;
	while(scanf("%lf %lf",&n,&k)!=EOF)
	{
		x=pow(k,1/n);
		x+=0.5; 
		printf("%d\n",(int )x);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值