Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12944 Accepted Submission(s): 4018
Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
Input
One positive integer on each line, the value of n.
Output
If the minimum x exists, print a line with 2^x mod n = 1.
Print 2^? mod n = 1 otherwise.
You should replace x and n with specific numbers.
Sample Input
2
5
Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1
#include<stdio.h>
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int d=0,s=1;
if(n%2==0||n==1)
{
printf("2^? mod %d = 1\n",n);
}
else
{
while(1)
{
s*=2;d++;
s%=n;
if(s%n==1)
{
printf("2^%d mod %d = 1\n",d,n);
break;
}
}
}
}
}