Girls and Boys
Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11519 Accepted Submission(s): 5406
Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:
the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)
The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
Sample Output
5 2
Source
思路:二分图的最大独立集 = 节点数-最大匹配数,这道题目给的图是无向图,所以求出的cnt应该除2;
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;
int n,m,vis[1505],link[1505];
vector<int>p[1505];
int find(int u){
for(int i = 0; i < p[u].size(); i ++){
int v = p[u][i];
if(!vis[v]){
vis[v] = 1;
if(link[v] == -1 || find(link[v])){
link[v] = u;
return 1;
}
}
}
return 0;
}
int main(){
while(~scanf("%d",&n)){
for(int i = 0; i <= n; i ++)
p[i].clear();
int a,b;
for(int i = 0; i < n; i ++){
scanf("%d: (%d)",&a,&m);
for(int j = 0; j < m; j ++){
scanf("%d",&b);
p[a].push_back(b);
}
}
int cnt = 0;
memset(link,-1,sizeof(link));
for(int i = 0; i < n; i ++){
memset(vis,0,sizeof(vis));
if(find(i))
cnt ++;
}
printf("%d\n",n-cnt/2);
}
return 0;
}