Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43015 Accepted Submission(s): 19094
Total Submission(s): 43015 Accepted Submission(s): 19094
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
题目意思是:给一个数n,求一个在n以内的自然数组成的素数环,要求
1.相邻的两个自然数之和为素数。
2.顺序输出所有数,逆序输出所有数。
这题用DFS做时,由于N<20时,可以打个素数表。慢慢地把条件理出来,注意标记过用过的数,进行进一步深收后,要把标记过的数撤回标记。
#include <iostream>
#include <string.h>
using namespace std;
int mark[20],a[20],n;
int prime[40]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};
void dfs(int s)
{
int i;
if(s==n+1&&prime[a[n]+a[1]])
{
for(i=1;i<n;i++)
cout<<a[i]<<" ";
cout<<a[n]<<endl;
}
else{
for(i=2;i<=n;i++)
{
if(!mark[i]&&prime[i+a[s-1]])
{
a[s]=i;
mark[i]=1;
dfs(s+1);
mark[i]=0;
}
}
}
}
int main()
{
int i,k;
k=1;
a[1]=1;
while(cin>>n)
{
memset(mark,0,sizeof(mark));
cout<<"Case "<<k++<<":"<<endl;
dfs(2);
cout<<endl;
}
return 0;
}