Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 13408 | Accepted: 3722 |
Description
- Every candidate can place exactly one poster on the wall.
- All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
- The wall is divided into segments and the width of each segment is one byte.
- Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
Output
The picture below illustrates the case of the sample input.

Sample Input
1 5 1 4 2 6 8 10 3 4 7 10
Sample Output
4
Source
#include<stdio.h>
#include<algorithm>
#include<string.h>
#define LL(x) (x<<1)
#define RR(x) (x<<1|1)
using namespace std;
struct T
{
int num,id,flag,t;
} s[20010];
struct Seg_Tree
{
int left,right,col;
int mid() { return (left+right)/2;}
}tree[30010*2*3];
int x[10010],y[10010],ans;
bool flag[20010*3];
bool cmp(T a, T b)
{
return a.num<b.num;
}
void build(int l,int r,int idx)
{
tree[idx].left=l;
tree[idx].right=r;
tree[idx].col=-1;
if(l==r) return ;
int mid=tree[idx].mid();
build(l,mid,LL(idx));
build(mid+1,r,RR(idx));
}
void update(int l,int r,int c,int idx)
{
if(l<=tree[idx].left&&r>=tree[idx].right)
{
tree[idx].col=c;
return;
}
if(tree[idx].col!=-1)
{
tree[LL(idx)].col=tree[RR(idx)].col=tree[idx].col;
tree[idx].col=-1;
}
int mid=tree[idx].mid();
if(l<=mid) update(l,r,c,LL(idx));
if(r>mid) update(l,r,c,RR(idx));
}
void query(int l,int r,int idx)
{
if(tree[idx].col!=-1)
{
if(!flag[tree[idx].col])
{
ans++;
flag[tree[idx].col]=true;
}
return;//important
}
int mid=tree[idx].mid();
if(l<=mid) query(l,r,LL(idx));
if(r>mid) query(l,r,RR(idx));
}
int main()
{
int T,n;
scanf("%d",&T);
while(T--)
{
memset(flag,false,sizeof(flag));
scanf("%d",&n);
for(int i=0; i<n; i++)
{
scanf("%d%d",&x[i],&y[i]);
s[2*i].id=i;
s[2*i].num=x[i];
s[2*i].flag=0;
s[2*i+1].id=i;
s[2*i+1].num=y[i];
s[2*i+1].flag=1;
}
sort(s,s+2*n,cmp);
s[0].t=0;
for(int i=1; i<2*n; i++)
if(s[i].num!=s[i-1].num)
{
if(s[i].num-1>s[i-1].num) s[i].t=s[i-1].t+2;
else s[i].t=s[i-1].t+1;
}
else
s[i].t=s[i-1].t;
for(int i=0; i<2*n; i++)
if(s[i].flag==0) x[s[i].id]=s[i].t;
else y[s[i].id]=s[i].t;
build(0,s[2*n-1].t,1);
for(int i=0; i<n; i++) update(x[i],y[i],i,1);
ans=0;
query(0,s[2*n-1].t,1);
printf("%d/n",ans);
}
return 0;
}