POJ 2528 Mayor's posters

本文介绍了一个使用线段树解决竞选海报放置与可见性判断的问题。在一场市长选举中,为了规范竞选海报的张贴,城市建立了专门的墙面,并规定每个候选人只能张贴一张海报。随着竞选活动的进行,新海报可能会覆盖旧海报,最终本文通过线段树算法解决了可见海报数量的问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

线段树NB!63MS...
Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13408 Accepted: 3722

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

 

#include<stdio.h>

#include<algorithm>

#include<string.h>

#define LL(x)  (x<<1)

#define RR(x)  (x<<1|1)

using namespace std;

struct  T

{

    int num,id,flag,t;

} s[20010];

struct Seg_Tree

{

    int left,right,col;

    int mid() { return (left+right)/2;}

}tree[30010*2*3];

int x[10010],y[10010],ans;

bool flag[20010*3];

bool cmp(T a, T b)

{

    return a.num<b.num;

}

void build(int l,int r,int idx)

{

    tree[idx].left=l;

    tree[idx].right=r;

    tree[idx].col=-1;

    if(l==r)   return ;

    int mid=tree[idx].mid();

    build(l,mid,LL(idx));

    build(mid+1,r,RR(idx));

}

void update(int l,int r,int c,int idx)

{

    if(l<=tree[idx].left&&r>=tree[idx].right)

    {

        tree[idx].col=c;

        return;

    }

    if(tree[idx].col!=-1)

    {

        tree[LL(idx)].col=tree[RR(idx)].col=tree[idx].col;

        tree[idx].col=-1;

    }

    int mid=tree[idx].mid();

    if(l<=mid)  update(l,r,c,LL(idx));

    if(r>mid)  update(l,r,c,RR(idx));

}

void query(int l,int r,int idx)

{

    if(tree[idx].col!=-1)

    {

        if(!flag[tree[idx].col])

        {

            ans++;

            flag[tree[idx].col]=true;

        }

        return;//important

    }

    int mid=tree[idx].mid();

    if(l<=mid)  query(l,r,LL(idx));

    if(r>mid)  query(l,r,RR(idx));

}

int main()

{

    int T,n;

    scanf("%d",&T);

    while(T--)

    {

        memset(flag,false,sizeof(flag));

        scanf("%d",&n);

        for(int i=0; i<n; i++)

        {

            scanf("%d%d",&x[i],&y[i]);

            s[2*i].id=i;

            s[2*i].num=x[i];

            s[2*i].flag=0;

            s[2*i+1].id=i;

            s[2*i+1].num=y[i];

            s[2*i+1].flag=1;

        }

        sort(s,s+2*n,cmp);

        s[0].t=0;

        for(int i=1; i<2*n; i++)

            if(s[i].num!=s[i-1].num)

            {

                if(s[i].num-1>s[i-1].num)  s[i].t=s[i-1].t+2;

                        else  s[i].t=s[i-1].t+1;

            }

            else

                s[i].t=s[i-1].t;

        for(int i=0; i<2*n; i++)

            if(s[i].flag==0) x[s[i].id]=s[i].t;

                        else y[s[i].id]=s[i].t;

        build(0,s[2*n-1].t,1);

        for(int i=0; i<n; i++)  update(x[i],y[i],i,1);

        ans=0;

        query(0,s[2*n-1].t,1);

        printf("%d/n",ans);

    }

    return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值