HDU2767 Proving Equivalences 图的强联通性

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 205    Accepted Submission(s): 89


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
  
  
2 4 0 3 2 1 2 1 3
 

Sample Output
  
  
4 2
 

Source
 

Recommend
lcy
#include<stdio.h>
#define MAX_SIZE 20008
int stack[MAX_SIZE];
int in[MAX_SIZE],out[MAX_SIZE];//题目中要求记录出度和入度的数组
bool instack[MAX_SIZE];
int N,M,b_cnt,idx,top;
struct Edge
{
    int adj;//adj
    Edge* next;//point to next
};
struct Node
{
    int DFN,LOW;//定义DFN(u)为节点u搜索的次序编号(时间戳),Low(u)为u或u的子树能够追溯到的最早的栈中节点的次序号。
    int belongs;//belongs to B_cnt,属于哪一个强联通分支
    Edge *first;//point to first,形成链状
} node[MAX_SIZE];
void Init() //initial node[],in[],out[]
{
    for(int i=0; i<=N; i++)
    {
        node[i].first=NULL;
        node[i].DFN=node[i].LOW=0;
        node[i].belongs=0;
        instack[i]=false;
        in[i]=out[i]=0;//不在模板中
    }
}
void InsertEdge(int u,int v) //insert edge u->v
{
    Edge*p=new Edge;
    p->adj=v;//指向的下一个节点
    p->next=node[u].first;
    node[u].first=p;
}
void Tarjan(int u) //Tarjan
{
    int v;
    node[u].DFN=node[u].LOW=(++idx);
    instack[u]=true;
    stack[++top]=u;
    for(Edge*p=node[u].first; p; p=p->next)
    {
        v=p->adj;
        if(!node[v].DFN)
        {
            Tarjan(v);
            if(node[v].LOW<node[u].LOW)
                node[u].LOW=node[v].LOW;
        }
        else if(instack[v]&&node[v].DFN<node[u].LOW)
            node[u].LOW=node[v].DFN;
    }
    if(node[u].DFN==node[u].LOW)
    {
        b_cnt++;
        do
        {
            v=stack[top--];
            instack[v]=false;
            node[v].belongs=b_cnt;
        }
        while(u!=v);
    }
}
void Tarjan_SCC() //StronglyConnectedComponent
{
    int i,t1,t2;
    b_cnt=idx=top=0;//b_cnt 新图的点数
    for(i=1; i<=N; i++)
        if(!node[i].DFN)
            Tarjan(i);
    if(b_cnt<=1)
        puts("0");
    else
    {
        for(i=1; i<=N; i++)
            for(Edge*p=node[i].first; p; p=p->next)
                if(node[i].belongs!=node[p->adj].belongs)
                    in[node[i].belongs]++,out[node[p->adj].belongs]++;
        t1=t2=0;
        for(i=1; i<=b_cnt; i++)
        {
            if(!in[i])t1++;
            if(!out[i])t2++;
        }
        printf("%d/n",t1>t2?t1:t2);
    }
}
int main()
{
    int i,u,v;
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&N,&M);
        Init();
        for(i=0; i<M; i++)
        {
            scanf("%d%d",&u,&v);
            InsertEdge(u,v);
        }
        Tarjan_SCC();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值