PAT A1007. Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4


/******************************侯尼玛******************************/

最大连续子串和,最基础的动态规划题目,因为之前有在书上看到过,没什么障碍就写出来了。

这道题的动态规划思想非常简单:

(1)记录以第i位为结尾的所有连续子串中,sum最大的那一个连续子串的sum和起始点。举两个例子————串{1 2 34 5 6}中,以3为尾时,最大连续子串和为6(1+2+3),起始点为1;在串{-1 -2 3 4 5 6}中,以3为尾时,最大连续子串和为3,起始点就是3。

(2)在(1)的基础上,考虑第i+1位。以第i+1位为尾的最大连续子串有两种可能,一是直接加在以i为尾的最大连续子串后;二是与之前的最大连续子串分割开来,单独作为一个子串。举两个相应的例子————如串{1 2 34 5 6}中,若第i+1位为4,就属于第一种情况;而在串{-1 0 -24 5 6}中,若第i+1位为4,则属于第二种情况。

(3)通过(1)和(2)的方法记录以每一位为尾的最大连续子串和,再遍历一边找出最大的连续子串和与起始点,就能AC了。

另外这道题需要注意的一点是两个额外的要求:一是当最大连续子串和一样的时候,选择起始点和结尾点序号最小的那个;二是如果每一位都为负数时(虽然不严谨,但是当 成是最大连续子串和小于0也能AC),最大连续子串和直接输出0,起始点值输出整个串的起始值,结尾点值输出整个串的结尾点值。

附上代码:

#include <iostream>

using namespace std;

int main()
{
    int num;
    while(cin>>num)
    {
        int *Sequence = new int [num+1];
        for(int i=0;i<num;i++)
        {
            cin>>Sequence[i];
        }
        int *MAXSequenceSum = new int [num+1];//以i为尾的子串中最大连续子串和的值
        int *SequenceBegin = new int [num+1];//以i为尾的子串中最大连续子串和的起始点
        MAXSequenceSum[0]=Sequence[0];
        SequenceBegin[0]=0;
        for(int i=1;i<num;i++)
        {
            if(MAXSequenceSum[i-1]+Sequence[i]>=Sequence[i])
            {
                MAXSequenceSum[i]=MAXSequenceSum[i-1]+Sequence[i];
                SequenceBegin[i]=SequenceBegin[i-1];
            }
            else
            {
                MAXSequenceSum[i]=Sequence[i];
                SequenceBegin[i]=i;
            }
        }

        int MAXSum=-0x7FFFFFFF,MAXEnd=0;//遍历找出最大连续子串和
        for(int i=0;i<num;i++)
        {
            if(MAXSequenceSum[i]>MAXSum)
            {
                MAXEnd=i;
                MAXSum=MAXSequenceSum[i];
            }
        }
        if(MAXSum<0)
            cout<<0<<' '<<Sequence[0]<<' '<<Sequence[num-1];
        else
            cout<<MAXSum<<' '<<Sequence[SequenceBegin[MAXEnd]]<<' '<<Sequence[MAXEnd];
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值