【算法练习】01背包求第k优解-hdu2639 bone collectorII

博客介绍了一种解题思路,在每次状态转移时,用两个数组保存所有可能成为新状态前k优解的值,接着对这两个数组排序,最后得出前k优解作为新状态。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

这题的主要思路是,每一次状态转移都用两个数组将所有可能成为新状态前k优解的值都保存下来,然后对这两个数组进行排序,再得出这两个数组的前k优解,作为新状态。

 

 

 

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6930    Accepted Submission(s): 3678


 

Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

3

5 10 2

1 2 3 4 5

5 4 3 2 1

5 10 12

1 2 3 4 5

5 4 3 2 1

5 10 16

1 2 3 4 5

5 4 3 2 1

 

 

Sample Output

 

12 2 0

 

 

#include<iostream>
#include<string.h>
#include<iomanip>
#include<algorithm>
using namespace std;
int volume[105];
int value[105];
int dp[100001][35];

int main(){
	int T;
	cin>>T;
	while(T--){
		int N,V,K;
		cin>>N>>V>>K;
		memset(volume,0,sizeof(volume));
		memset(value,0,sizeof(value));
		memset(dp,0,sizeof(dp));

		int index=0;

		for(int i=1;i<=N;i++){
			cin>>value[i];
		}
		for(int i=1;i<=N;i++){
			cin>>volume[i];
			
		}

 
		int a[35]={0};
		int b[35]={0};
		
		for(int i=1;i<=N;i++){
			for(int j=V;j>=volume[i];j--){
				int k;
				for( k=1;k<=K;k++){
					a[k]=dp[j][k];
					b[k]=dp[j-volume[i]][k]+value[i];
				}
				a[k]=-1;
				b[k]=-1;
				int ai=1;
				int bi=1;
				int ci=1;
				for(ci=1;ci<=K&&(a[ai]!=-1||b[bi]!=-1);){
					if(a[ai]>=b[bi]){
						dp[j][ci]=a[ai];
						ai++;
					} else{
						dp[j][ci]=b[bi];
						bi++;
					}
					if(dp[j][ci]!=dp[j][ci-1]){
						ci++;
					}
				} 
			}

		} 
		cout<<dp[V][K]<<endl;
		
	}
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值