Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
Input
The first line contains a number NN (N≤106N≤106),representing the number of operations.
Next NN line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109109.
Output
For each operation 3,output a line representing the answer.
Sample Input
6
1 2
1 3
3
1 3
1 4
3
Sample Output
3
4
分析:STL中的multiset
不能用cin cout 即使加速也不行 会T
#include <cstdio>
#include <iostream>
#include <cstring>
#include <map>
#include <set>
#include <bitset>
#include <cctype>
#include <cstdlib>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <string>
#include <vector>
#include <sstream>
#include <functional>
#include <algorithm>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
#define memc(a,b) memcpy(a,b,sizeof(b))
#define rep(i,a,n) for(int i=a;i<n;i++) ///[a,n)
#define dec(i,n,a) for(int i=n;i>=a;i--)///[n,a]
#define pb push_back
#define IO ios::sync_with_stdio(false)
#define fre freopen("in.txt","r",stdin)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long ll;
typedef unsigned long long ull;
const double PI=acos(-1.0);
const double eps=1e-8;
const double e=2.7182818;
const int INF=0x3f3f3f3f;
const int MOD=998244353;
const int N=1e6+5;
const ll maxn=5e4;
const int dir[4][2]= {-1,0,1,0,0,-1,0,1};
multiset<int>mst;
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int x,y;
scanf("%d",&x);
int maxx=0;
multiset<int>::iterator it=mst.begin();
if(x==1)
{
scanf("%d",&y);
mst.insert(y);
}
else
{
if(x==2)
{
if(mst.empty()) continue;
else
{
it=mst.begin();
mst.erase(it);
}
}
else
{
if(mst.empty()) puts("0");
else
{
it=mst.end();
--it;
printf("%d\n",(*it));
}
}
}
}
return 0;
}