POJ1470/ZOJ1141 Closest Common Ancestors(LCA离线算法)

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)
Input
The data set, which is read from a the std input, starts with the tree description, in the form: 

nr_of_vertices 
vertex:(nr_of_successors) successor1 successor2 ... successorn 
... 
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form: 
nr_of_pairs 
(u v) (x y) ... 

The input file contents several data sets (at least one). 
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
Output
For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times 
For example, for the following tree: 
Sample Input
5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)
Sample Output
2:1
5:5
Hint
Huge input, scanf is recommended.

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#include<vector>
#define nn 1001
#define mm 500001
#define inff 0x3fffffff
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
int fa[nn],n,m,num,num1;
int vis[nn];
int ans[nn];
int sum[nn];
int p[nn],p1[nn];
struct node
{
    int en,next;
}q[mm],e[mm];
int add(int st,int en)
{
    e[num].en=en;e[num].next=p[st];p[st]=num++;
}
int add1(int st,int en)
{
    q[num1].en=en;q[num1].next=p1[st];
    p1[st]=num1++;
}
void init()
{
    memset(vis,0,sizeof(vis));
    memset(ans,0,sizeof(ans));
    memset(sum,0,sizeof(sum));
    memset(p,-1,sizeof(p));
    memset(p1,-1,sizeof(p1));
    num=num1=0;
    for(int i=1;i<=n;i++)
        fa[i]=i;
}
int find(int u)
{
    while(u!=fa[u])
        u=fa[u];
    return u;
}
void dfs(int u)
{
    for(int i=p[u];i+1;i=e[i].next)
    {
        int v=e[i].en;
        dfs(v);
        fa[v]=u;
    }
    for(int i=p1[u];i+1;i=q[i].next)
    {
        int v=q[i].en;
        if(vis[v])
        {
            int aim=find(v);
            ans[aim]++;
        }
    }
    vis[u]=1;
}
int main()
{
    int u,v,t;
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<=n;i++)
        {
            scanf("\t%d\t:\t(\t%d\t)",&u,&t);
            for(int i=1;i<=t;i++)
            {
                scanf("\t%d\t",&v);
                add(u,v);
                sum[v]=1;
            }
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            getchar();
            scanf("\t(%d\t %d\t)",&u,&v);
             add1(u,v);
             add1(v,u);
        }
     int ff;
     for(ff=1;ff<=n;ff++)
        if(!sum[ff]) break;
     dfs(ff);
        for(int i=1;i<=n;i++)
        {
            if(ans[i])
            {
                printf("%d:%d\n",i,ans[i]);
            }
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值