03-树1 树的同构(25 分)
给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。

图1
图2
输入格式:
输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (≤10),即该树的结点数(此时假设结点从0到N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。
输出格式:
如果两棵树是同构的,输出“Yes”,否则输出“No”。
输入样例1(对应图1):
8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
输出样例1:
Yes
输入样例2(对应图2):
8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
输出样例2:
No
作者: 陈越
单位: 浙江大学
时间限制: 400ms
内存限制: 64MB
代码长度限制
#include <iostream>
#include <string>
using namespace std;
#define MaxNodeNum 10
#define Empty -1
template<class T>
struct BinTreeNode
{
T data;
int left;
int right;
bool isRoot;
BinTreeNode(const T& d = (T)0) : data(d), left(Empty), right(Empty), isRoot(true) {}
};
BinTreeNode<char> tree1[MaxNodeNum], tree2[MaxNodeNum];
template<class T>
int createTree(BinTreeNode<T> *node)
{
int nodeNum = 0;
cin >> nodeNum;
if (nodeNum == 0)
return Empty;
for (int i = 0; i < nodeNum; i++)
{
char lc, rc;
cin >> node[i].data >> lc >> rc;
if (lc != '-')
{
lc -= '0';
node[i].left = lc;
node[lc].isRoot = false;
}
if (rc != '-')
{
rc -= '0';
node[i].right = rc;
node[rc].isRoot = false;
}
}
int root = 0;
for (int i = 0; i < nodeNum; i++)
{
if(node[i].isRoot)
{
root = i;
break;
}
}
return root;
}
bool Isomprphic(int root1, int root2)
{
if ((root1 == Empty) && (root2 == Empty))//根节点都是空,同构
return true;
if (((root1 == Empty) && (root2 != Empty)) || ((root1 != Empty) && (root2 == Empty)))//根节点有一个为空
return false;
if (tree1[root1].data != tree2[root2].data) //根数据不同,不同构
return false;
bool a = (Isomprphic(tree1[root1].left, tree2[root2].left) && Isomprphic(tree1[root1].right, tree2[root2].right));
bool b = (Isomprphic(tree1[root1].left, tree2[root2].right) && Isomprphic(tree1[root1].right, tree2[root2].left));
return a || b;
}
int main()
{
int root1 = 0, root2 = 0;
root1 = createTree(tree1);
root2 = createTree(tree2);
if (Isomprphic(root1, root2))
cout << "Yes" << endl;
else
cout << "No" << endl;
system("pause");
return 0;
}