*递推 - 矩阵快速幂解斐波拉契数

本文介绍使用矩阵快速幂求解斐波那契数列的方法,并应用于寻找特定条件下最小的“坏”正整数。通过矩阵运算提高算法效率,解决大数问题,并提供代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目:number number number

Problem Description

We define a sequence F:
F0=0,F1=1;
Fn=Fn-1+Fn-2 (n≥2).
Give you an integer k, if a positive number n can be expressed by
n=Fa1+Fa2+…+Fak where 0≤a1≤a2≤……≤ak, this positive number is mjf?good. Otherwise, this positive number is mjf?bad.
Now, give you an integer k, you task is to find the minimal positive mjf?bad number.
The answer may be too large. Please print the answer modulo 998244353.

Input

There are about 500 test cases, end up with EOF.
Each test case includes an integer k which is described above. (1≤k≤109)

Output

For each case, output the minimal mjf?bad number mod 998244353.

Sample Input

1

Sample Output

4

矩阵快速幂解斐波拉契数

矩阵快速幂与快速幂思想相同。
分析斐波拉契数论,f[i] = 1*f[i-1]+1*f[i-2]。

由f[i] = 1*f[i-1]+1*f[i-2]和f[i-1] = 1*f[i-1] + 0*f[i-2];我们可以给出矩阵形式。
这里写图片描述
所以,递推矩阵有

注:这里完全可以不用vector,用LL a[2][2]即可,vector可能超时。

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

typedef long long LL;
const LL mod=998244353;
typedef vector<LL> vec;
typedef vector<vec> mat;

mat mul(mat &a,mat &b)
{
    mat c(a.size(),vec(b[0].size()));
    for(int i=0; i<2; i++)
    {
        for(int j=0; j<2; j++)
        {
            for(int k=0; k<2; k++)
            {
                c[i][j]+=a[i][k]*b[k][j];
                c[i][j]%=mod;
            }
        }
    }
    return c;
}
mat pow(mat a,LL n)
{
    mat res(a.size(),vec(a.size()));
    for(int i=0; i<a.size(); i++)
        res[i][i]=1;//单位矩阵;
    while(n)
    {
        if(n&1) res=mul(res,a);
        a=mul(a,a);
        n/=2;
    }
    return res;
}
LL fib(LL n)
{
    mat a(2,vec(2));
    a[0][0]=1;
    a[0][1]=1;
    a[1][0]=1;
    a[1][1]=0;
    a=pow(a,n);
    return a[0][1];//也可以是a[1][0];
}
int  main()
{

    LL n;
    while(scanf("%lld",&n)==1)
    {
        printf("%lld\n",fib(2*n+3)-1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值