Cow Exhibition
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 8534 | Accepted: 3181 |
Description
"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons
The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.
Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
fun..."
- Cows with Guns by Dana Lyons
The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.
Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows
* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.
Sample Input
5 -5 7 8 -6 6 -3 2 1 -8 -5
Sample Output
8
Hint
OUTPUT DETAILS:
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
大致题意:给定n个牛的信息(智慧度和幽默度),选择一些牛,使得所有牛的智慧+幽默总和最大,
而且智慧和>=0,幽默和>=0,如果不存在则输出0.
解题思路:实际上就是选择n个物品,装入背包,使得结果最大。
1.幽默度存在负的,所以要初始化为-oo;
2.如何解决智慧度为负的,可以使用坐标平移,原智慧最小值为-100,000,则向有平移100,000
使其最小值为0,当遇到智慧度>0时,就使用倒序遍历,从最大(200,000)的开始.
当遇到智慧<0时要正序遍历,我认为实际也相当于从最大的开始,只不过原智慧越小,abs(智慧)越大。
总结:ans[top] = max(ans[top], ans[top-w[i]]+c[i]) (正序,倒序是一样的)
源码:
使其最小值为0,当遇到智慧度>0时,就使用倒序遍历,从最大(200,000)的开始.
当遇到智慧<0时要正序遍历,我认为实际也相当于从最大的开始,只不过原智慧越小,abs(智慧)越大。
总结:ans[top] = max(ans[top], ans[top-w[i]]+c[i]) (正序,倒序是一样的)
源码:
#include <stdio.h>
#include <string.h>
#define N (2*100*1000)
int ans[N+10];
int w[110], c[110];
int n;
int max(int a, int b)
{
return a>b?a:b;
}
int dp()
{
memset(ans, 0x8f, sizeof(ans)); // 设置为-OO (01背包恰好装满,只是背包的容量未知)
ans[100000] = 0; // 原点为0
int top;
for (int i=0; i<n; ++i)
{
if (w[i] > 0) // 重量>0,按照正常的01背包
{
for (top = N; top>=w[i]; --top)
{
ans[top] = max(ans[top], ans[top-w[i]] + c[i]);
}
}
else // 如果<0, 则要从0开始,其实也是左边的最大值因为w[i]小于0越小越大
{
for (top = 0; top<=N+w[i]; ++top)
{
ans[top] = max(ans[top], ans[top-w[i]] + c[i]);
}
}
}
int m = 0;
for (int i=100000; i<=N; ++i) // 最后找到最大的一个(因为i表示牛的总智慧,i从100000开始,所以要减掉100000)
{
if (ans[i] > 0 && m < ans[i]+i-100000)
{
m = ans[i]+i-100000;
}
}
return m;
}
int main()
{
while (~scanf("%d", &n))
{
for (int i=0; i<n; ++i)
{
scanf("%d%d", &w[i], &c[i]);
}
printf("%d\n", dp());
}
return 0;
}