1001 A+B Format (20 point(s))
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
Tips:
1. 注意%d、%3d(补充空格)、%03d(补充0)。
//区分%d %3d %03d %.3d
#include<iostream>
#include<cstring>
using namespace std;
int main(void)
{
int a,b;
scanf("%d%d",&a,&b);
int sum = a + b;
if(sum<0){
printf("-");
sum = -sum;
}
if(sum>=1000000){
int x=sum/1000000;
printf("%d,",x);
int y=sum-x*1000000;
printf("%03d,",y/1000);
printf("%03d",y%1000);
}
else if(sum<1000000&&sum>=1000){
printf("%d,%03d",sum/1000,sum%1000);
}
else{
printf("%d",sum);
}
return 0;
}
https://pintia.cn/problem-sets/994805342720868352/problems/994805528788582400