1122 Hamiltonian Cycle (25 point(s))

1122 Hamiltonian Cycle (25 point(s))

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

哈密顿圈的定义和判定。

哈密顿圈需要满足:

1. 首尾结点相同;

2. 覆盖图中的每一个结点且只能经过1次;

注意点:输入的序列数组长度可以超过N,否则case#4会因为越界出现WA。对于没有指明的长度,请用vector。 又浪费了好多时间TAT

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
const int MAX = 207;
int N,M,K;
bool visit[MAX];
bool graph[MAX][MAX]={false};
vector<int> seq;
int main(void){
	cin>>N>>M;int a,b;
	memset(graph,false,sizeof(graph));
	for(int i=0;i<M;i++){
		cin>>a>>b;
		graph[a][b]=true;
		graph[b][a]=true;
	}
	cin>>K;int c,x;
	while(K--){
		bool flag = true;
		cin>>c;
		seq.clear();
		for(int i=0;i<c;i++){
			cin>>x;
			seq.push_back(x);
		};
		if(c!=N+1||seq[0]!=seq[c-1]){
			flag = false;
		}
		else{
			for(int i=1;i<=N;i++) visit[i]=false;
			for(int i=0;i+1<c;i++){
				if(!graph[seq[i]][seq[i+1]]){
					flag =false;
					break;
				}
				
					visit[seq[i+1]]=true;
				
			}
			if(flag){
				for(int i=1;i<=N;i++){
					if(!visit[i]){
						flag = false;
						break;
					}
				}				
			}
		}
		if(flag) puts("YES");
		else puts("NO");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值