1125 Chain the Ropes (25 point(s))

1125 Chain the Ropes (25 point(s))

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

贪心策略、Huffman树

要使得绳子的长度尽可能长,那么要使得每一次消耗掉的尽可能短(每次选出的两根绳子的一半尽可能短),因此每次贪心地选择最短的两根绳子即可。可以采用优先队列,建立小顶堆即可。

数学证明

实际上,对于这道题,由于刚好是一半,也就是选出的最短的两根的一半再放回去以后,仍然是最短的。

假设c \geq b\geq a,必然有c \geq \frac{a+b}{2},因此实际上排序以后遍历即可。

Huffman

#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
int N;
priority_queue<int,vector<int> , greater<int> > Q;
int main(void){
	cin>>N;double x;
	for(int i=0;i<N;i++){
		cin>>x;
		Q.push(x);
	}
	while(Q.size()>=2){
		double a = Q.top();
		Q.pop();
		double b = Q.top();
		Q.pop();
		Q.push(0.5*(a+b));
	}
	cout<<(int)(Q.top()+0.5);
	return 0; 
} 

数学

#include<bits/stdc++.h>
using namespace std;
int main(){
    int N;
    scanf("%d",&N);
    double A[N];
    for(int i=0;i<N;++i)
        scanf("%lf",&A[i]);
    sort(A,A+N);//排序
    double sum=A[0];
    for(int i=1;i<N;++i)
        sum=sum/2+A[i]/2;//对折两根绳子
    printf("%d",(int)floor(sum));//向下取整
    return 0;
}

参考链接:https://blog.youkuaiyun.com/richenyunqi/article/details/79795133

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值